Scolring - Forum

Entraides et échanges autour de la technologie Scol - Informations and exchanges on the Scol technology

Vous pouvez changer la langue de l'interface une fois inscrit - You can change the language once registered

You are not logged in.

#1 17-Jul-2019 22:07:52

jasolo
Member
Registered: 2-Apr-2017
Posts: 20

Google Play's target API level requirement

From https://developer.android.com/distribut … t-sdk.html :
When you upload an APK, it needs to meet Google Play’s target API level requirements. Starting August 1, 2019, Google Play requires that new apps target at least Android 9.0 (API level 28), and that app updates target Android 9.0 from November 1, 2019. Until these dates, new apps and app updates must target at least Android 8.0 (API level 26).

I have created an APK for arm64 with Openspace3D 1.80 and after the upload Google Play says my app targets API level 26. Can I target level 28? Maybe with a future update of the Android plugin?

Other problem with my AR app is the size of the APK using the Default option. It seems to contain the 32 and 64 bits versions, so the size is greater than 100 MB and Google Play does not accept the APK. I have to create both versions separately (arm32 and arm64). That is the solution?

Offline

#2 18-Jul-2019 09:36:02

Xeonadow
Scol language & OpenSpace3D developer
Registered: 28-Jul-2017
Posts: 66

Re: Google Play's target API level requirement

Thank you for letting us know.
The next version of OpenSpace3D (which will hopefully release in a few weeks) will export application for API 28.

About the size of your application, the default export contains every version (x86, x86_64, armeabi-v7a and arm64-v8a), so it is indeed bigger. Creating both versions separately is a very good solution as it decreases the size of the application both for your upload and the final user that download it from the Play Store. The next version of OpenSpace3D will also feature the App Bundle export, that has a higher upload limit and let the Play Store automatically generates the smallest apk for the final user.

Last edited by Xeonadow (18-Jul-2019 09:36:53)

Offline

#3 30-Jul-2020 11:00:54

shahbiz8
Member
From: Malaysia
Registered: 25-Feb-2016
Posts: 291

Re: Google Play's target API level requirement

New info..

By August 3, 2020, new apps must target at least Android 10 (API level 29). By November 2, 2020, all apps that are being updated must target at least Android 10 (API level 29).

Offline

#4 31-Jul-2020 08:55:38

arkeon
Admin. / Scol language & OpenSpace3D developer
From: Nantes
Registered: 30-Mar-2009
Posts: 4,682
Website

Re: Google Play's target API level requirement

doh! we missed that again ^^ thanks for the info.
We will update this for a release in september.

Offline

Board footer

Powered by FluxBB