Scolring - Forum

Entraides et échanges autour de la technologie Scol - Informations and exchanges on the Scol technology

Vous pouvez changer la langue de l'interface une fois inscrit - You can change the language once registered

You are not logged in.

#1 3-Jan-2016 17:19:38

Admin. / Scol language & Scol apps developer
From: France
Registered: 22-Feb-2009
Posts: 2,024

Scol under GNU / Linux and Wine

Scol under GNU / Linux via Wine.

Test OK :
- OS : Debian stretch (9)
- Arch : 64-bits
- Wine : 1.9.0
- Graphics card : nVidia GT430, driver : proprietary (test ok with "Nouveau" too)
- Free OpenGL API version : 11.0.8

Note : At this time, security.dll is always not loaded by Scol. So, OpenSpace3D can not work directly. In this case, apply this patch first :
Note : SCS and other programs work perfectly.
Note : same result with PlayOnLinux ! (and maybe PlayOnMac ??)

1/ On Debian (and all based Debian Linux distros, like Ubuntu, Mint, ...), if you are in 64-bits, enable the 32-bits support.
As root, in Debian :

# dpkg --add-architecture i386

and update your packages list :

# apt-get update

Note : This operation may be required on other distros, i don't know. Adapt these commands, if any.

2/ Install the latest version of wine from the official web site or from your distro repository.

3/ Download and install Scol from the Scolring.

4/ Launch Scol (scol.exe) : by default from /home/YOUR_LOGIN/.wine/drive_c/Program Files/Scol

5/ Click right on the Scol icon and select "Settings".
Check the following tabs :
- SO3Engine : if present, check the configuration;
- 3D params (legacy 3d engine) : if present, check the configuration;
- Webcam : if present, check the configuration;

6/ If all is ok, that's all ! smile


"Hey ! I've a problem ! It doesn't work !"

A/ If you are a problem to install or use Wine, please consult the Wine website :

B/ After install, Scol is not found in the system files.
By default, Wine creates an hidden folder in your HOME directory. You must activate "Show the hidden entry" in your files manager.

C/ After install, Scol seems not to start.
First, please wait : Wine should start before Scol.
If Scol seems not really start :
- check if a Scol process currently exists or not. If you have not a GUI interface for that, open a terminal and enter :

$ ps -le

If no Scol enter is present, ok, else kill it (them) with the killall command.
- edit the usmuser.ini file in a basic text editor (avoid an office suite !) : typically, usmuser.ini is in /home/YOUR_LOGIN/Documents/Scol
- replace (or add) "log no" by "log yes"
- replace (or add) "echo 0" by "echo 1f"
- save it (you could perform before a backup).
- Relaunch Scol. If any, kill the process.
- In your system files, go to /home/YOUR_LOGIN/.wine/drive_c/users/YOUR_LOGIN/Local Settings/Application Data/Scol/Logs
- If no log file is present, it seems that you launch the program badly. See the Wine web site for informations to use Wine correctly.
- Otherwise, in a text editor, open the latest log file.
- If you don't understand, paste the content in an appropriate Scolring section.

D/ In the "Settings" interface, the "Webcam" tab is empty.
Are you connect the webcam in your host ?
Are you install the MS windows driver under Wine ?
If yes, visit the WineHQ web site and check if your webcam driver is supported.

E/ In the "Settings" interface, the "SO3Engine" tab is not present.
The DirectX support is not loaded in Wine.
- Exit Scol.
- Go to
- In the most cases, choose link
- Download the archive and extract it.
- Copy "d3d11.dll", "dxgi.dll" "libwine.dll" and "wined3d.dll" in your Scol directory. Typically in /home/YOUR_LOGIN/.wine/drive_c/Program Files/Scol
/!\ Be careful, don't copy these files in the windows/system32 Wine directory !
- In Debian (and based Debian distros) and on 64-bits architecture, you could install also the 32-bits OpenGL API :

# apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

- If your graphics card driver is proprietary, you may install too the OpenGL API device. By example, for nVidia on Debian :

# apt-get install libgl1-nvidia-glx
# apt-get install libgl1-nvidia-glx:i386	// on 64-bits architecture only

- Restart Scol.
- If the problem persists, see the C section above (to activate and read the log file).

Note : if you ignore the current driver, you may use this command in a terminal :

$ grep /drivers/ /var/log/Xorg.0.log

F/ In the "Settings" interface, the "Legacy 3D engine" tab is not present.
Same thing than the E section above.

G/ Scol starts correctly but a Scol application crashes.
Activate the log. For that, please see the C section above.

H/ Scol applications run normally but the 3D is empty (or "disabled", "grey", etc).
Clic right on the Scol icon and choose "Settings". Check the 3D configuration.

I/ I've another Scol problem under Wine.
Open a new topic in an appropriate section in the Scolring forum.


Board footer

Powered by FluxBB